HyperX Cloud Alpha – Mic not working on Win10

Updated on April 14, 2019 in Devices
5 on October 30, 2018

Hey! i just bought a new headset for my brand new desktop, and the mic isn’t working..

There seems to be absolutely No signal coming from the mic as I can’t get the green bars to rise in the recording device section of Sound options.

I have Tried deleting and reinstalling different drivers (Realtek) – both from manufacturer’s homepage and from Microsoft’s catalogue, rebooting my desktop between every deletion and installation. didn’t work…

I already checked the privacy settings regarding mic and webcam and it’s set properly.

Every time i installed new drivers, i checked and adjusted levels in “microphone properties”, and disabled sound effects under “Enhancements” and set communication settings to “do nothing”.

I believed it was a hardware problem and therefore went to get a new headset in the store – same problem.
I checked the new headset on another Windows 10 desktop – same problem.

It did work when i checked it on a laptop running Windows 7, so im fairly sure it ain’t a hardware issue.

I did all of the above with the jacksticks in the two ports in the front of my pc, and went on to make Windows go back to before i tampered with drivers, to start from scratch – repeating the steps with the jacksticks in the back of my pc. Still No Sound from the mic..

Im running Windows 10 64bit
on a ASUS Prime z370-a motherboard.
My newly purchased headset is a Hyperx Cloud Alpha with a splitted Jackstick 3.5mm.

Please work ur magic and pull out a trick from ur sleeve that I have forgotten or don’t know!

Thx !

 
  • Liked by
Reply
2 on October 30, 2018

Hello Relasher,

I see you’ve already done a lot to make it work, and yet it doesn’t which is bad. I would suggest a few things and hopefully something will work.

According to HyperX Cloud Alpha page on hyperx website, there are a lot of problems regarding Windows 10, but they suggest that you make sure you’ve inserted the cable correctly (fully inserted and no grey visible)

They also suggest that you go to the Control Panel>device manager and go to Sound, video and game controllers section. Find Realtek High Definition Audio listed, right click on it and choose uninstall. Once this is done, go to the following page to download the updated driver. 

http://www.realtek.com/downloads/

Select High Definition Audio Codecs (software) link. Download the latest version that is correct for your Windows version and install it. You may need to restart your computer. Once this is done, plug the headset back in and test the microphone.

There is more here: https://www.hyperxgaming.com/us/support/technical/products?model=hx-hsca

See if any of this works and I’ll be looking for more solutions for you.

on October 30, 2018

Hey Mina

– checking the cable was the absolute first thing i did, and the next thing was deleting the old driver and installing the newest version from their website – which just left me with a faulty Realtek Audio Manager… 

But !
I just figured out the problem ! 😀 

I just realized that i had a seperate audio manager installed (NVIDIA HDA) for my monitor (ROG Swift PG248Q) – I made Windows go back to the pre-installed drivers, deactivated the NVIDIA driver and did a reboot, and everything works fine now. 

Thank u for your time and fast reply anyways 🙂 !

 

 

on October 30, 2018

Oh that’s great! I’m happy you could solve it. I’ll advise people to do as you said and maybe it will solve their problem too. Thank you so much, we appreciate your reply ☺

Show more replies
  • Liked by
Reply
Cancel

I’m trying to get the mic to work on my headphones, and am looking at all the REALTEK downloads for windows. do i have to download ALL of the files, or just select ones? If there are only a few I need, what are they? 

  • Liked by
Reply
Cancel
0 on April 14, 2019

No, try to download the latest one. If it doesn’t work, I would suggest that you head for the official website of your laptop/computer/motherboard’s manufacturer, you’ll find the compatible driver there. 

  • Liked by
Reply
Cancel