Microphone won’t turn on when connected to audio interface

Updated on March 10, 2019 in Devices
1 on March 10, 2019

I have a Samson Q2U Microphone and a Focusrite 2i2 2nd generation audio interface.  My PC is also running Windows 10.

So here is my problem:  I had connected my microphone to the interface and the interface to my computer (via usb) once before and I could record just fine.  Today, I tried plugging in the devices and my microphone won’t turn on.  I have the Focusrite audio driver installed and the audio interface has a green light on showing it is connected to my computer.  Yet, why isn’t my microphone on?  And I have tried just plugging my microphone in directly to my computer, just to verify it works, and I could record audio.  

Please help me figure out how I can turn on the microphone so that I can record audio into it while it is connected to my computer via audio interface.  

 
  • Liked by
Reply
0 on March 10, 2019

Hello melss94, I’ve looked up both devices in order to do my best guessing the possible issues. I see the microphone works when you connect it to the PC directly, I think you’re using the USB cable inserted to the USB output in the microphone (am I right about this of you’re using some audio converters in between?). But when you plug the microphone to the audio interface, you can’t record… which leads us to one of these issues:

Please try these and tell me how it went, I’ll do my best to help you further. Good luck!

  • Liked by
Reply
Cancel